Avviso importante: tutti i testi di questo sito web sono stati tradotti da diverse lingue. Ci scusiamo per la loro qualità, potrebbe essere di qualità inferiore al solito. Saluti, l'Amministrazione del sito. E-mail: [email protected]

Come installare Java in OS X El Capitan

Alcuni utenti Mac richiedono l’installazione di Java in OS X El Capitan, forse per compatibilità con un particolare sito Web o applicazione, o perché sono uno sviluppatore Java. Ma Apple sta diventando sempre più severa con Java, e per impostazione predefinita non è più installata con un’installazione pulita di OS X 10.11, e scoprirai che dopo aver aggiornato un Mac una versione precedente di JRE o JDK potrebbe non funzionare più.

Inoltre, quando si tenta di utilizzare alcune applicazioni o contenuti Web specifici, è possibile che venga visualizzato “Questa applicazione richiede il runtime Java SE 6 precedente non disponibile per questa versione di OS X.” messaggio di errore, che significa che se si desidera eseguirlo app hai bisogno di usare una versione precedente di Java.

In ogni caso, se hai bisogno di Java JRE o Java JDK in OS X 10.11 o successivo, ecco come puoi installarlo.

Per essere chiari, se non hai bisogno di Java, non dovresti installare Java. E se non sei sicuro se hai bisogno di Java o meno, significa che probabilmente non hai affatto bisogno di Java, e puoi anche evitare di installare java.

Gli utenti Mac potrebbero dover disattivare la protezione SIP rootless in OS X prima di poter installare Java correttamente, ma è possibile riattivarlo dopo averlo installato. Se rimani bloccato su “verifica …” durante il processo di installazione di Java, è a causa di rootless.

Installa Java SE 6 in OS X El Capitan di Apple

È possibile installare versioni precedenti di Java in OS X El Capitan utilizzando il programma di installazione Java per OS X 2015-001, che include Java 6. Per essere chiari, Java 6 è una versione del 2013, obsoleta e non più supportata da Oracle , ha vari buchi di sicurezza conosciuti ed è quindi inappropriato per la maggior parte degli utenti Mac da installare senza un motivo valido. Quindi, a meno che tu non abbia bisogno di Java 6 in particolare, probabilmente vorrai avere una versione più recente, o se non hai affatto bisogno di Java, non installarlo.

  • Ottieni legacy Java per OS X 2015-001 da Apple

Questo scaricherà un programma di installazione che è possibile utilizzare per OS X El Capitan (e Yosemite e Mavericks per questo).

Se ti imbatti in errori durante l’installazione, è perché hai sfogliato l’introduzione e non hai disabilitato SIP / rootless su Mac. Fallo per primo e Java si installerà bene.

Installa Java 8 in OS X EL Capitan da Oracle

L’altra opzione è quella di ottenere la versione di Java più recente disponibile da Oracle. Puoi iniziare in due modi:

  • Aprire un terminale e digitare “java -version”, quindi fare clic sul pulsante “Ulteriori informazioni” per passare alla pagina dei download Java
  • Oppure vai alla pagina dei download Java direttamente qui su Oracle.com dove puoi trovare JRE e JDK

Installa java in OS X El Capitan

Di nuovo, sarà probabilmente necessario disabilitare la protezione SIP sul Mac prima di poter completare l’installazione.

Like this post? Please share to your friends: